[MacPorts] #66068: git 2.38.1_0 "Failed to patch git: command execution failed"

MacPorts noreply at macports.org
Wed Oct 26 10:26:23 UTC 2022

#66068: git 2.38.1_0 "Failed to patch git: command execution failed"
 Reporter:  stevenlovegrove  |      Owner:  (none)
     Type:  defect           |     Status:  new
 Priority:  Normal           |  Milestone:
Component:  ports            |    Version:  2.8.0
 Keywords:  failed patch     |       Port:  git
 I'm receiving an error when attempting to install git that it failed to
 apply a patch (full log attached). I had just synced with selfupdate to

 I first received the error on Monterey. I eventually resorted to wiping
 macports by uninstalled installed and removing /opt/local. Installing git
 as the first command failed with the same error.

 I then upgraded to Ventura, installed the corresponding macports package
 from your website, uninstalled installed ports, removed /opt/local,
 upgraded XCode etc, and received the same error, so it seems to be a
 general problem with 2.8.0? I'm running on an M1 mac.

Ticket URL: <https://trac.macports.org/ticket/66068>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list