[MacPorts] #63786: opencv3/opencv4: opportunistic lib usage: tesseract, ogre, etc

MacPorts noreply at macports.org
Sat Sep 10 23:50:21 UTC 2022

#63786: opencv3/opencv4: opportunistic lib usage: tesseract, ogre, etc
  Reporter:  mascguy          |      Owner:  mascguy
      Type:  defect           |     Status:  reopened
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.7.1
Resolution:                   |   Keywords:
      Port:  opencv3 opencv4  |

Comment (by cooljeanius):

 Replying to [comment:12 cooljeanius]:
 > Replying to [comment:8 mascguy]:
 > > Replying to [comment:7 mascguy]:
 > > > I've tested with virtually all variants enabled, from 10.8 thru
 Monterey, and all looks good.
 > > >
 > > > With one caveat: `+openni` fails for Monterey, and might have issues
 on Big Sur as well. Can you try without that variant?
 > >
 > > Just tested with trace mode enabled for 10.15, Big Sur, and Monterey,
 with variants: `+contrib+eigen+gdal+java+nonfree+opencl+qt5+tbb`. And only
 Monterey failed, with a similar failure to yours (for module `gapi`).
 > >
 > > Looks like a linking issue. But there isn't a clear error regarding
 missing symbols and such, so need to dig into it further. (And appears to
 only occur with trace mode enabled.)
 > >
 > > Can you also remove variants `+debug` and `+tests` - in addition to
 removing `+openni` - to pare things down a bit?
 > I'm trying removing them one at a time; with `+debug` removed it still
 fails with the same error; I'll try `+tests` next...

 Update: removing `+tests` and `+openni` doesn't help; the build still
 fails with the same error even with those removed.

Ticket URL: <https://trac.macports.org/ticket/63786#comment:14>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list