[MacPorts] #65853: qt5-qtbase fails to configure

MacPorts noreply at macports.org
Tue Sep 20 00:57:29 UTC 2022

#65853: qt5-qtbase fails to configure
  Reporter:  AgilentGCMS  |      Owner:  (none)
      Type:  defect       |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:  2.7.2
Resolution:               |   Keywords:
      Port:  qt5-qtbase   |

Comment (by AgilentGCMS):

 Replying to [comment:4 MStraeten]:
 > temporary workaround:
 > use a user specific Portfile

 I tried this workaround, but qt5 still doesn't build. This is what my
 (modified) port file looks like around line 1386:
             # do not use ${configure.sdk_version}
             # SDK is recorded in ${qt_mkspecs_dir}/qdevice.pri
             # SDK may then be removed if Xcode is updated
             # see https://trac.macports.org/ticket/54044
             # see https://trac.macports.org/ticket/55195
             configure.args-append \
                 -sdk macosx
             configure.sdk_version 12.3 \
             # configure options that don't show up in configure --help
             configure.args-append \
                 -no-libudev       \
 All I did was add that line `configure.sdk_version 12.3 \` there.
 Apologies if I'm making an obvious mistake; I use ports to make my macOS
 more linux-like, but I have no idea how the innards work.

 The error message I got was
 --->  Configuring qt5-qtbase
 Error: Failed to configure qt5-qtbase: configure failure: command
 execution failed
 Error: See
 for details.
 Attaching main.log here.

Ticket URL: <https://trac.macports.org/ticket/65853#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list