[MacPorts] #66885: tk+quartz fails to build on aarch64

MacPorts noreply at macports.org
Sat Feb 11 14:58:58 UTC 2023

#66885: tk+quartz fails to build on aarch64
  Reporter:  tux-o-matic  |      Owner:  MarcusCalhoun-Lopez
      Type:  defect       |     Status:  assigned
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:  2.8.1
Resolution:               |   Keywords:
      Port:  tk           |

Comment (by tux-o-matic):

 Failed attempt (Didn't save the log at the time but it failed about
 % sudo port install tk +quartz
 --->  Computing dependencies for tk
 --->  Fetching archive for tk
 --->  Attempting to fetch tk-8.6.13_0+quartz.darwin_22.arm64.tbz2 from
 --->  Fetching distfiles for tk
 --->  Verifying checksums for tk
 --->  Extracting tk
 --->  Applying patches to tk
 --->  Configuring tk
 Warning: Configuration logfiles contain indications of -Wimplicit-
 function-declaration; check that features were not accidentally disabled:
   stat64: found in tk8.6.13/unix/config.log
 --->  Building tk
 Error: Failed to build tk: command execution failed
 Error: See
 for details.
 Error: Follow https://guide.macports.org/#project.tickets if you believe
 there is a bug.

 Installed the standard x11 variant of tk (which worked), now uninstalled
 it to try again the quartz variant and this time it worked...

 Probably can close the ticket unless someone can think of an explanation
 between the cycle of x11 install then quartz variant working

Ticket URL: <https://trac.macports.org/ticket/66885#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list