(no subject)

Merton Campbell Crockett m.c.crockett at adelphia.net
Fri Dec 29 15:07:13 PST 2006

On 29 Dec 2006, at 14:07:46, James Coyle wrote:

> In attempting to install MacPorts, I've run into a little problem.
> Since I already have Fink on my system, the latest 10.4 developer  
> tools and X11 had been installed earlier. I downloaded and  
> installed the MacPorts binary, and then using pico, opened and  
> edited the ~./profile and it now looks like this:
>> # Your previous .profile  (if any) is saved as .profile.dpsaved
>> # Setting the path for DarwinPorts.
>> export PATH=/opt/local/bin:/opt/local/sbin:$PATH
>> export DISPLAY=:O.O
> However, when I run the env command, I get this:
>> PATH=/sw/bin:/sw/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin
>> HOME=/Users/jamescoy
>> SHELL=/bin/tcsh
>> USER=jamescoy
>> TERM_PROGRAM=Apple_Terminal
>> TERM=xterm-color
>> LOGNAME=jamescoy
>> HOSTTYPE=powermac
>> VENDOR=apple
>> OSTYPE=darwin
>> MACHTYPE=powerpc
>> SHLVL=1
>> PWD=/Users/jamescoy
>> GROUP=staff
>> HOST=James-Coyles-iBook.local
>> MANPATH=/sw/share/man:/usr/share/man:/usr/X11R6/man:/sw/lib/ 
>> perl5/5.8.6/man:/sw/lib/perl5-core/5.8.1/man:/sw/lib/perl5/5.8.1/man
>> INFOPATH=/sw/share/info:/sw/info:/usr/share/info
>> PERL5LIB=/sw/lib/perl5:/sw/lib/perl5/darwin
>> XML_CATALOG_FILES=/sw/etc/xml/catalog
>> SGML_CATALOG_FILES=/sw/etc/sgml/catalog
> As you can see, the PATH does not display as per the instructions.  
> Is that because of Fink being on my system or.....what's the deal?   
> Thanks!

I ran into similar problems without Fink being installed.  I found  
that I had to change the file name to ~./.bash_profile to get  
consistent results.  Also, as I tend to use an X Terminal instead of  
the Apple Terminal, I discovered that I needed to add the "-ls"  
switch to the ~./.xinitrc file and the X11 Terminal application.

Merton Campbell Crockett
m.c.crockett at adelphia.net

More information about the macports-users mailing list