libidl and flex problem

Edward Thome edthome at
Mon Sep 25 06:44:47 PDT 2006

On Sep 24, 2006, at 4:54 AM, Bengt Nilsson wrote:

> Hi!
> I have tried to do a "port upgrade installed", but it does not  
> complete.
> Repeatedly, I get this for libidl:
> --->  Activating libidl 0.8.6_0
> --->  Deactivating libidl 0.8.6_0
> --->  Configuring libidl


> checking for yywrap in -lfl... yes
> checking lex output file root... configure: error: cannot find  
> output from flex; giving up
> What could the problem be?
> I have tried uninstall, clean and install libsdl, no luck.
> Also, I suspect my port registry is corrupt, since I often get  
> complaints about reigrered port confiltcts (e.g. file exists but  
> does not belong to any registered ports). Can it be rebuilt?


I had the same problem.  I rebuilt flex with:

sudo port -f uninstall flex; sudo port clean --all flex; sudo port  
install flex

and then libidl built just fine.

Ed Thome

More information about the macports-users mailing list