Fail to install DP

Mark Duling mark.duling at
Sat Sep 30 00:28:22 PDT 2006

Stefani Gerber <stefani.gerber at> writes:
>The update to DarwinPorts 1.3.1 failed on my G4 PowerBook so I figured,
>I'd rather delete DP and install it again from scratch. Uninstall went
>fine (sudo rm -rf /opt/local /Applications/DarwinPorts
>/Library/Tcl/darwinports1.0 /Library/StartupItems/DarwinPortsStartup ),
>but when I try to install DP 1.3.2, I get the output below (sorry for
>posting it all, I just don't know where the important information is in
>I also tried to install DP 1.3.1 from dmg (by installer), but when I do
>a "sudo port -d selfupdate", I get the same error as for make.
>I also updated XCode and should be using gcc 4.0.1 now
>huni-3:/Volumes/Work/teufental/browser/DarwinPorts-1.3.2 ted$ gcc_select
>Current default compiler:
>gcc version 4.0.1 (Apple Computer, Inc. build 5363)
>huni-3:/Volumes/Work/teufental/browser/DarwinPorts-1.3.2 ted$
>Does anyone have any tips/hints for me? I just couldn't find anything on
>this problem

I'd just install the 1.3.1 dmg binary and then when you do a selfupdate it
will update to 1.3.2 and also get the latest ports.  It is confusing the
way the installers are at the moment.


More information about the macports-users mailing list