Removing out-of-date packages

Kevin Ballard eridius at
Thu Feb 1 08:29:33 PST 2007

I just talked to pipping on the IRC channel and he said trying `sudo  
port uninstall inactive` worked for him correctly when he tried again.

Incidentally, `port list` is always going to show the current version  
of the port, regardless of what you have installed. Try using `port  
echo inactive` if you want to see your inactive ports. Alternately  
you could use `port installed inactive`, though that's kinda  
redundant as anything in the inactive list is known to be installed.

And yes, if the inactive pseudo-portname resolves to nothing, port  
list is going to show everything. There may be a way to detect this  
condition and get it to show nothing, but I don't know if it's worth  
the effort.

On Feb 1, 2007, at 10:47 AM, Elias Pipping wrote:

> "inactive" is somewhat broken, i believe. (that's why i wouldn't  
> recommend using "sudo port -f uninstall inactive" but a "port  
> uninstall inactive" first to make sure the right things are  
> uninstalled.
> e.g. i had optipng 0.5.4, upgraded to 0.5.5.
> so 0.5.4 is inactive, 0.5.5 is active
> "port list inactive" lists optipng 0.5.5
> "(sudo) port uninstall inactive" uninstalls optipng 0.5.5
> also, "port list inactive" appears to display every single port  
> there is (yes even those you don't have installed) if you don't  
> have any inactive ports.

Kevin Ballard
eridius at

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list