Missing CHOLMOD in octave 2.9.9

M. White mwhite15 at woh.rr.com
Sun Feb 18 18:33:50 PST 2007

Hi,  I am not exactly if this is the correct place to ask this  
question or not - my apologies if misplaced.

I just installed octave 2.9.9 using darwinports 1.3.2 and tried to  
run a small matrix test case for matlab (mytrit.m from Johan Helsing  
of Lund University).  When I try to run it, it gets to the line:


and I get the error message:

     error: Missing CHOLMOD. Sparse cholesky factorization disabled

[If I comment out that section, everything else seems to run fine.]

Now as near as I can tell cholmod should be part of SuiteSparse  
(which was also installed [v. 2.4.0_0] as part of this process).  The  
headers for cholmod are found in "/opt/local/include/ufsparse".   
Unless there was some error in the installation that was not  
reported, I should have CHLMOD I think.  There is also a chol.oct  
found in "/opt/local/libexec/octave/2.9.9/oct/powerpc-apple- 

Unfortunately, the I did not try to build it verbose - and cannot  
find any log or error files that might point out what actually  
happened.  Does anyone have any ideas on what I possibly did wrong  
and how I might fix it?

I have a copy of 2.1.73 which was installed from binaries provided by  
hpc.sourcefourge.net last year in /usr/local/bin - but /opt/local/bin  
comes first in my path.  I had originally tried to install the 2.9.9  
binaries from there, but it complained because I did not have UMFPACK  
(probably because I did not have ufsparse at that time).

Thank you for your time.

  - M.

P.S. running Mac OS-X 10.4.8 on a G4.

More information about the macports-users mailing list