nedit problem

Georg Otto georg.otto at
Thu Feb 22 01:26:43 PST 2007

Dear Daniel,

"Daniel J. Luke" <dluke at> writes:

> On Feb 21, 2007, at 1:25 PM, Georg Otto wrote:
>> I followed your suggestion but I still get the same error.
>> $ nedit file.txt
>> dyld: Library not loaded: /opt/local/lib/libpng12.0.dylib
>>   Referenced from: /opt/local/lib/libXm.4.dylib
>>   Reason: Incompatible library version: libXm.4.dylib requires
>> version 17.0.0 or later, but libpng12.0.dylib provides version 0.1.2
>> Trace/BPT trap
> what does
> otool -L /opt/local/lib/libpng12.0.dylib
> say?
> you could try:
> port sync
> port -f uninstall libpng
> port clean --all libpng
> port install libpng
> just in case there's something wrong with your libpng install
> Also, make sure you don't have any of the DYLD_* environment
> variables set.

It turned out that the last suggestion actually brought the
solution. My DYLD_LIBRARY_PATH was set in my shell environment due to
an old installation of another program. I removed it and now nedit can
be started.

Thanks a lot!


More information about the macports-users mailing list