emacs install breaking

Rob MacLeod macleod at cvrti.utah.edu
Mon Feb 26 21:29:42 PST 2007


I am trying to get emacs working from MacPorts and my first try would  
not launch its own X-window but ran in the xterm where I launched  
it.  It also reported a warning that the directory


was missing, which it was when I went looking.  I am not sure what  
this directory does or whether its absence explains why emacs was lamed.

I am now trying to do a fresh install of emacs but running into  
problems.  I keep getting this error during installation:

--->  Activating emacs 21.4a_1+darwin_8
Error: Target com.apple.activate returned: File exists
Error: Status 1 encountered during processing.

I have tried uninstalling emacs using

	sudo port uninstall emacs
and then

	sudo port clean --all emacs

and still I get this same error.

Does anyone have any guesses about what might be going wrong.

As background, I have used fink since the beginning of OSX time, used  
emacs on Unix for many more years before that.  I am trying to move  
from Fink to Macports but so far, the experience is mixed.  I left  
Fink because it was falling behind on new versions.  I hope MacPorts  
will work for me...



Rob MacLeod, Ph.D.
University of Utah
Dept. of Bioengineering, CVRTI, and SCI (www.sci.utah.edu)
95 South 2000 East Room 207
Salt Lake City, Utah 84112-5000                 ____  __o
Internet:  macleod at cvrti.utah.edu              ____   -\<,
Phonemail: (801)587-9511                         ....0/ 0
Fax:       (801)581-3128
URL:       www.cvrti.utah.edu/~macleod
Nora Eccles Harrison Cardiovascular Research and Training Institute

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.macosforge.org/pipermail/macports-users/attachments/20070226/8937a269/attachment.html

More information about the macports-users mailing list