(no subject)

P.J. Rusello pjr25 at cornell.edu
Fri Jun 15 07:50:26 PDT 2007

I installed Xfig in the hopes of being able to draw some schematics  
for an upcoming project. Everything on the install went fine, Xfig  
starts, but crashes every time with the following error:

xfig3.2.5: SIGBUS signal trapped
xfig: figure empty or not modified - exiting
Abort trap

The menus are all empty (i.e. I can select "File" but there's nothing  
in it to select) as well. I can draw shapes before the crash and the  
files are auto-saved by Xfig without a problem if I modify them.

I came across this thread:


And the last post in it suggests Xaw3d is the problem. I modified the  
Portfile (sudo port edit Xfig) by deleting the port:Xaw3d line from  
the depends_lib section and tried reinstalling Xfig (after  
uninstalling it). Same problem, same error, still crashing before I  
get a chance to meddle.

Am I doing something wrong in the Portfile edit where Macports is  
using a different version and ignoring my edits, or is the problem  
not associated with Xaw3d like the last post in the thread I linked  
to? Any help would be really appreciated. Thanks!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.macosforge.org/pipermail/macports-users/attachments/20070615/7cee4813/attachment.html

More information about the macports-users mailing list