Installs dead in the water with MacPorts

Ryan Schmidt ryandesign at
Tue Mar 20 16:08:13 PDT 2007

On Mar 20, 2007, at 17:45, Ken Pettit wrote:

> System: 1.5Ghz G4 PPC Laptop
> OS: OSX 10.4.8
> DarwinPorts base version 1.4
> I got this error:
> --->  Building freetype with target all
> Error: Target returned: shell command "cd "/opt/ 
> local/var/db/dports/build/ 
> _opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_ 
> dports_print_freetype/work/freetype-2.1.10" && make all" returned  
> error 2
> Command output: / No such file or directory
> / No such file or directory
> make: *** No rule to make target `/'.  Stop.
> Error: The following dependencies failed to build: libgsf gnome-vfs  
> gconf gtk2 pango Xft2 fontconfig freetype xrender render cairo tiff  
> jpeg libbonobo intltool p5-xml-parser perl5.8 orbit2 libidl popt  
> gnome-mime-data heimdal howl
> Error: Status 1 encountered during processing.
> kardia-3:~ Kardia$
> Now I keep getting this error when I try to install any port.

I don't know what to make of it. I also have a 1.5-GHz PowerBook G4.  
freetype 2.1.10 was already installed, but I told it to forcibly  
reinstall it, and it worked fine.

You get this error when installing any port because those other ports  
all depend on freetype? Or are we talking about other ports that have  
nothing to do with freetype? If so, can you show us that output?

Others seem to have this problem with freetype 2.1.10 on other  
platforms, like this:

Have you tried to clean the work area and start again? "sudo port  
clean --work freetype", then "sudo port install freetype"?

Do you have Fink installed, or anything in /usr/local that might be  
interfering with the MacPorts build?

More information about the macports-users mailing list