Bus Error using SSLeay

Ken Bowlus orgz at mac.com
Tue Mar 20 16:45:52 PDT 2007

Thanks, Ryan.  Much to my surprise that worked.  I only say "much to  
my surprise" because I had built the port against  the libraries on  
my machine.  I then uninstalled it, made sure all my ports were  
upgraded, ran clean, then reinstalled the port and I had the same  
result.  I had done this all last night.  I noticed when I ran the  
command that you gave me that after it fetched and installed the  
port, it deactivated and uninstalled a previous version of that  
port.  I should have looked specifically at what version of the port  
I had installed but, since I had installed it yesterday and upgraded  
all installed ports, I assumed that Ihad the latest (that was a good  
learning experience)!  Now, I'm a little confused as to what really  
happened but this helps me for the next time I run into a problem  
(maybe I should have used the -f option).

Thanks again!

On Mar 20, 2007, at 3:55 PM, Ryan Schmidt wrote:

> On Mar 20, 2007, at 17:22, orgz at mac.com wrote:
>> I'm using the current SSLeay module (p5-crypt-ssleay) module in a  
>> perl script that is trying to get an https URL but it always fails  
>> and reports a bus error (i.e., no bus error on http URLs).  I am  
>> running Mac OS X 1.4.9 and have XCode 2.4.1 installed.  I think  
>> 10.4.9 may be the problem because the mod date for libmx.A.dylib  
>> looks like it was the day I installed 10.4.9.  So, I'm looking for  
>> confirmation from those who know better that this is probably the  
>> case and to see if there is an reasonable solution to fix this  
>> problem.  Or, would I have to restore to a pre-10.4.9 state? All  
>> of my ports are up to date. Here is the perl crash log:
>> Binary Images Description:
>>     0x1000 -    0xfdfff perl 	/opt/local/bin/perl
>>   0x11e000 -   0x125fff Parser.bundle 	/opt/local/lib/perl5/ 
>> vendor_perl/5.8.8/darwin-2level/auto/HTML/Parser/Parser.bundle
>>   0x129000 -   0x12bfff IO.bundle 	/opt/local/lib/perl5/5.8.8/ 
>> darwin-2level/auto/IO/IO.bundle
>>   0x12e000 -   0x131fff Socket.bundle 	/opt/local/lib/perl5/5.8.8/ 
>> darwin-2level/auto/Socket/Socket.bundle
>>   0x138000 -   0x139fff Base64.bundle 	/opt/local/lib/perl5/5.8.8/ 
>> darwin-2level/auto/MIME/Base64/Base64.bundle
>>   0x13c000 -   0x140fff SSLeay.bundle 	/opt/local/lib/perl5/ 
>> vendor_perl/5.8.8/darwin-2level/auto/Crypt/SSLeay/SSLeay.bundle
>>   0x144000 -   0x17afff libssl.0.9.8.dylib 	/opt/local/lib/libssl. 
>> 0.9.8.dylib
>>   0x190000 -   0x1a1fff libz.1.dylib 	/opt/local/lib/libz.1.dylib
>> 0x1205000 -  0x12f6fff libcrypto.0.9.8.dylib 	/opt/local/lib/ 
>> libcrypto.0.9.8.dylib
>> 0x8fe00000 - 0x8fe52fff dyld 46.12	/usr/lib/dyld
>> 0x90000000 - 0x901bdfff libSystem.B.dylib 	/usr/lib/libSystem.B.dylib
>> 0x90215000 - 0x9021afff libmathCommon.A.dylib 	/usr/lib/system/ 
>> libmathCommon.A.dylib
>> 0x94c90000 - 0x94cb2fff libmx.A.dylib 	/usr/lib/libmx.A.dylib
> I don't know what libmx is... but maybe you should try rebuilding  
> the troublesome port? Thereby rebuilding it against the version of  
> the libraries that are currently on your system? "sudo port -ncuf  
> upgrade <portname>"

More information about the macports-users mailing list