Qt4 port

Jochen Küpper jochen at fhi-berlin.mpg.de
Sat Nov 3 14:45:39 PDT 2007

On 03.11.2007, at 22:28, Adam Dershowitz wrote:

>> On 24.10.2007, at 06:46, Adam Dershowitz wrote:
>>> I just noticed that 4.3.2_0 was now in macports.  So I tried doing:
>>> sudo port upgrade outdated
>>> and it worked just fine to go from 4.3.1_1.  This time I did not  
>>> have to first deactivate.

> Right after I did this install I built sqliteman (http:// 
> sqliteman.com/) a Qt gui application that was the reason that I  
> needed to include sqlite in Qt.  It built fine.
> Just yesterday I tried to use it, and it fails to open any  
> databases.  But that is the same error that I was getting when I  
> first tried to build the Qt port and sqlite was not an option.

What is the exact error message?

> The following ports are currently installed:
>   qt4-mac @4.3.2_0+sqlite (active)
> But is there any way to confirm that sqlite was actually being  
> included properly with Qt.  I know that it worked fine for the old  
> version that I first sent to you.  So something is different.  Any  
> ideas?

What does
   sudo port contents qt4-mac | grep sqlite
give you? I get this:

Since I have never used any real db with Qt: what is an easy way to  
check whether Qt's sqlite plugin works in a given installation?

Einigkeit und Recht und Freiheit                http://www.Jochen- 
     Liberté, Égalité, Fraternité                GnuPG key: CC1B0B4D
         Sex, drugs and rock-n-roll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://lists.macosforge.org/pipermail/macports-users/attachments/20071103/a3e9b4d4/PGP.bin

More information about the macports-users mailing list