Gnome-VFS Fails to Upgrade

Altoine Barker ndiscreet at
Sun Nov 18 10:51:50 PST 2007


You are correct. I was able to find a solution in the bug trac. A user
specified that they removed heimdal and that solved their problem and
were wondering if anyone else could confirm. A user with a Panther
setup, did as the user had said to do with heimdal and received a
different error complaining about not being able to find gssapi. I
received the exact same error. Then I realized that I didn't "clean" my
Mac Ports. Here are the steps I did to resolve my problem.

sudo port -v uninstall heimdal
sudo port -v clean --all gnome-vfs
sudo port -vu upgrade gnome-vfs

I am attempting to register now but it appears I have had once did that.
I am unable to remember my password, so I am awaiting the system to send
me a new one. Here is the solution until I get that worked out.


Ryan Schmidt wrote:
> On Nov 17, 2007, at 10:11, Altoine Barker wrote:
>> -I../.. -I../.. -I../../libgnomevfs -I../../libgnomevfs
>> -I/opt/local/include -no-cpp-precomp -O2 -MT ne_auth.lo -MD -MP -MF
>> .deps/ne_auth.Tpo -c ne_auth.c  -fno-common -DPIC -o .libs/ne_auth.o
>> In file included from ne_auth.c:66:
>> /usr/include/gssapi/gssapi_generic.h:46: error: syntax error before
>> 'extern'
>> /usr/include/gssapi/gssapi_generic.h:47: error: syntax error before
>> 'extern'
>> /usr/include/gssapi/gssapi_generic.h:48: error: syntax error before
>> 'extern'
>> /usr/include/gssapi/gssapi_generic.h:50: error: syntax error before
>> 'extern'
>> make[3]: *** [ne_auth.lo] Error 1
>> make[2]: *** [all-recursive] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
>> Warning: the following items did not execute (for gnome-vfs):
>> org.macports.destroot
>> Error: Unable to upgrade port: 1
>> My setup:
>> PowerPC G4
>> Mac OSX 10.4.10
>> Mac Ports 1.5.2
>> XCode 2.4.1
>> Actions:
>> sudo port -v clean --all gnome-vfs
>> ...and "clean --all" on all it's deps.
>> sudo port -vu upgrade outdated
>> ...and I still find myself with this error message.
> I think that's this error:
> You should read it and see if it helps you resolve the problem. I've
> also added your email address to the bug's Cc list so that you'll be
> informed of its progress.


.--. `
 __|  .-----.
|=.| |.-----.|
|--| ||Enter||
|  | |'-----'|

More information about the macports-users mailing list