problem with libraries path

Rémi Thébault rtbo.mailing at
Tue Nov 27 04:54:41 PST 2007


I have some problems with pathes and env. variables. It seems my  
system get confused and doesn't want in some situations to find  
libraries or headers elsewhere than /opt/local.

here is my profile file:

$ cat ~/.profile
# Your previous .profile  (if any) is saved as .profile.mpsaved
# Setting the path for MacPorts.
export PATH=/usr/local/bin:/usr/local/sbin:/opt/local/bin:/opt/local/ 
export C_INCLUDE_PATH=/usr/local/include:/opt/local/include:/sw/ 
export LIBRARY_PATH=/usr/local/lib:/opt/local/lib:/sw/lib:/usr/lib

I have for instance installed liblrdf in /usr/local and when I want to  
build Ardour from source (it uses scons instead of ./configure &&  
make) :

scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for gthread-2.0... yes
Checking for lrdf... no
lrdf >= 0.4.0 not found.
You do not have the necessary dependencies required to build ardour
Please consult for more information

a workaround is to install all dependencies in /opt/local, but I don't  
like it, and some of them (like JackOSX) cannot be installed elsewhere  
than /usr/local.

I would like to find a system wide way to make any building or  
configure script look first in /usr/local then in /opt/local to find  
whatever is needed (libraries or headers).
I assue this behaviour should be automatic but it's not, and I've  
never had this kind of problem on linux.

May be this a problem specific to scons ?
I've tried to specify CFLAGS : $ CFLAGS="-I/usr/local/include -I/opt/ 
local/include -I/usr/include" scons
but the same error occurs.

Intel Macbook, Leopard 10.5.1

More information about the macports-users mailing list