Getting "tcl wasn't compiled with threads enabled" error

Bernard Desgraupes bdesgraupes at
Sat Sep 1 05:34:06 PDT 2007

I'm having a problem trying to selfupdate MacPorts on my machine: the 
configure script stops on the following

checking for Tcl configuration... found /usr/local/lib/
checking for existence of /usr/local/lib/ loading
checking for Tcl public headers... /usr/local/include
checking for tclsh... /usr/bin/tclsh
checking for Tcl package directory... /Library/Tcl
checking whether tclsh was compiled with threads... no
configure: error: tcl wasn't compiled with threads enabled

I currently have MacPorts 1.5.0 installed from the .dmg archive.

My version of tclsh was 8.4.10 in /usr/bin and probably indeed it was 
not compiled with threads.

So I installed the MacPorts version of Tcl (sudo port install tcl) 
thinking that this one would be compiled with threads enabled. This 
installed version 8.4.15 in /opt/local/bin.

Then trying again to "port -selfupdate"

Same error and still the configure script finds tclsh in /usr/bin
checking for tclsh... /usr/bin/tclsh

So I changed the /usr/bin/tclsh symlink so that it points to the newly 
compiled tclsh:
lrwxr-xr-x   1 root  wheel  20 Sep  1 14:12 /usr/bin/tclsh -> 

Still I get the same error from the MacPorts configure script.

How can I get out of this ?
How do I do to have tclsh compiled with threads enabled? Apparently even 
with the MacPorts version it is not. I found the following line in 
    # Flag, 1: we built Tcl with threads enables, 0 we didn't

And why is the MacPorts configure script looking for the wrong Tcl. It 
is loading /usr/local/lib/



More information about the macports-users mailing list