Gimp - libgnome problems

Lenore Horner LenoreHorner at
Mon Sep 17 04:21:45 PDT 2007

I tried uninstalling, cleaning, and installing to no avail.  It's  
still looking for /opt/local/lib/libintl.3.dylib when I have /opt/ 
local/lib/libintl.8.dylib.  Output below.  I tried upgrading all my  
outdated stuff and had similar sorts of errors for librsvg, libgsf,  
gnome-vfs, libgnomecanvas, libglade2, libgnomevfs-2.


sudo port -f uninstall libgnome
Error: port uninstall failed: Registry error: libgnome not registered  
as installed.
[ppp-70-225-45-115:~]% sudo port clean --all libgnome
--->  Cleaning libgnome
[ppp-70-225-45-115:~]% sudo port install libgnome
--->  Fetching libgnome
--->  Attempting to fetch libgnome-2.19.1.tar.bz2 from http://
--->  Verifying checksum(s) for libgnome
--->  Extracting libgnome
--->  Configuring libgnome
--->  Building libgnome with target all
Error: Target returned: shell command " cd "/opt/ 
ibgnome/work/libgnome-2.19.1" && make all " returned error 2
Command output: In file included from /opt/local/include/ 
                  from /opt/local/include/libbonobo-2.0/bonobo/bonobo- 
                  from /opt/local/include/libbonobo-2.0/libbonobo.h:36,
                  from gnome-init.c:51:
/opt/local/include/glib-2.0/glib/gi18n.h:26:1: warning: "Q_" redefined
In file included from gnome-init.c:41:
/opt/local/include/glib-2.0/glib/gi18n-lib.h:31:1: warning: this is  
the location of the previous definition
gnome-init.c: In function 'libgnome_module_info_get':
gnome-init.c:535: warning: initialization discards qualifiers from  
pointer target type
gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I./.. -Wall -Wmissing-prototypes - 
D_REENTRANT -DORBIT2=1 -I/opt/local/include/glib-2.0 -I/opt/local/lib/ 
glib-2.0/include -I/opt/local/include -I/opt/local/include/gnome- 
vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/ 
bonobo-activation-2.0 -I/opt/local/include/libbonobo-2.0 -I/opt/local/ 
include/gconf/2 -I/opt/local/include/orbit-2.0 -DG_DISABLE_DEPRECATED  
-DLIBGNOME_PREFIX=\"/opt/local\" -DLIBGNOME_LIBDIR=\"/opt/local/lib\"  
opt/local/var\" -DLIBGNOME_SYSCONFDIR=\"/opt/local/etc\" - 
DG_LOG_DOMAIN=\"Gnome\" -I/opt/local/include -O2 -MT gnome-init.lo - 
MD -MP -MF .deps/gnome-init.Tpo -c gnome-init.c -o gnome-init.o >/dev/ 
null 2>&1
mv -f .deps/gnome-init.Tpo .deps/gnome-init.Plo
/bin/sh ../libtool --tag=CC   --mode=link gcc  -O2 -version-info  
1900:1:1900 -no-undefined -export-symbols-regex "^[^_].*" -L/opt/ 
local/lib -o -rpath /opt/local/lib  
libgnometypebuiltins.lo gnome-config.lo gnome-sound.lo gnome- 
triggers.lo gnome-program.lo gnome-help.lo gnome-exec.lo gnome- 
gconf.lo gnome-i18n.lo gnome-url.lo gnome-util.lo gnome-score.lo  
gnome-init.lo  -Wl,-framework,CoreAudio -L/opt/local/lib -lgnomevfs-2  
-lbonobo-2 -lbonobo-activation -lgconf-2 -lORBit-2 -lgmodule-2.0 - 
lgthread-2.0 -lgobject-2.0 -lglib-2.0 -lintl -liconv -lesd - 
laudiofile -lm   -lpopt
generating symbol list for `'
/usr/bin/nm -p  .libs/libgnometypebuiltins.o .libs/gnome- 
config.o .libs/gnome-sound.o .libs/gnome-triggers.o .libs/gnome- 
program.o .libs/gnome-help.o .libs/gnome-exec.o .libs/gnome- 
gconf.o .libs/gnome-i18n.o .libs/gnome-url.o .libs/gnome-util.o .libs/ 
gnome-score.o .libs/gnome-init.o  | sed -n -e 's/^.*[       ]\ 
([BCDEGRST][BCDEGRST]*\)[    ][      ]*_\([_A-Za-z][_A-Za-z0-9]*\)$/ 
\1 _\2 \2/p' | /usr/bin/sed 's/.* //' | sort | uniq > .libs/ 
/usr/bin/grep -E -e "^[^_].*" ".libs/libgnome-2.exp" > ".libs/ 
mv -f ".libs/libgnome-2.expT" ".libs/libgnome-2.exp"
sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < .libs/ 
libgnome-2.exp > .libs/libgnome-2-symbols.expsym
gcc -dynamiclib  -o .libs/libgnome-2.0.1900.1.dylib  .libs/ 
libgnometypebuiltins.o .libs/gnome-config.o .libs/gnome-sound.o .libs/ 
gnome-triggers.o .libs/gnome-program.o .libs/gnome-help.o .libs/gnome- 
exec.o .libs/gnome-gconf.o .libs/gnome-i18n.o .libs/gnome-url.o .libs/ 
gnome-util.o .libs/gnome-score.o .libs/gnome-init.o  -L/opt/local/ 
lib /opt/local/lib/libgnomevfs-2.dylib /opt/local/lib/ 
libORBitCosNaming-2.dylib /opt/local/lib/libxml2.dylib /opt/local/lib/ 
libssl.dylib /opt/local/lib/libcrypto.dylib /opt/local/lib/ 
libz.dylib /opt/local/lib/libbonobo-2.dylib /opt/local/lib/libbonobo- 
activation.dylib /opt/local/lib/libgconf-2.dylib /opt/local/lib/ 
libORBit-2.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/ 
libgthread-2.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/ 
lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib /opt/local/lib/ 
libiconv.dylib /opt/local/lib/libesd.dylib /opt/local/lib/ 
libaudiofile.dylib -lm /opt/local/lib/libpopt.dylib  -Wl,-framework - 
Wl,CoreAudio -install_name  /opt/local/lib/libgnome-2.0.dylib -Wl,- 
compatibility_version -Wl,1901 -Wl,-current_version -Wl,1901.1
ld: warning prebinding disabled because dependent library: /opt/local/ 
lib/libgnomevfs-2.0.dylib is not prebound
ld: warning can't open dynamic library: /opt/local/lib/libintl. 
3.dylib referenced from: /opt/local/lib/libgnomevfs-2.dylib (checking  
for undefined symbols may be affected) (No such file or directory,  
errno = 2)
ld: Undefined symbols:
_libintl_dgettext referenced from libgnomevfs-2 expected to be  
defined in /opt/local/lib/libintl.3.dylib
_libintl_dngettext referenced from libgnomevfs-2 expected to be  
defined in /opt/local/lib/libintl.3.dylib
_libintl_bind_textdomain_codeset referenced from libgnomevfs-2  
expected to be defined in /opt/local/lib/libintl.3.dylib
_libintl_bindtextdomain referenced from libgnomevfs-2 expected to be  
defined in /opt/local/lib/libintl.3.dylib
/usr/bin/libtool: internal link edit command failed
make[3]: *** [] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Time spent in user mode   (CPU seconds) : 25.618s
Time spent in kernel mode (CPU seconds) : 30.105s
Total time                              : 1:32.12s
CPU utilisation (percentage)            : 60.4%
Times the process was swapped           : 0
Times of major page faults              : 0
Times of minor page faults              : 0
Exit 1

On Sep 16, 2007, at 8:25 PM, Randall Wood wrote:

> On 16 Sep 2007, at 20:10, Lenore Horner wrote:
>> platform PowerBook G4, Macports 2.520
>> Gimp is currently faulting on libgnome which won't install on its  
>> own either.  Puzzling through the error output, I find
>> "ld: warning can't open dynamic library: /opt/local/lib/libintl. 
>> 3.dylib".
>> There is something very odd here.  By hand I can find /opt/local/ 
>> lib/libintl.8.dylib.  Is libgnome really that far out of date?   
>> Furthermore, "port installed libintl" reports "None of the  
>> specified ports are installed".  In addition, "port search  
>> libintl" yields "p5-libintl-perl                perl/p5-libintl- 
>> perl 1.16         Perl internationalization library" which seems  
>> to be neither what I have nor what I need.  I don't know what I  
>> have that caused libintl.8.dylib to be installed, so I don't know  
>> whether I can safely downgrade it.  I have doubts about trying to  
>> have two versions co-exist.
>> Suggestions?
> Try the following:
> sudo port -f uninstall libgnome
> sudo port clean --all libgnome
> sudo port install libgnome
> That should solve the linking error
>> Lenore
>> _______________________________________________
>> macports-users mailing list
>> macports-users at
> Randall Wood
> rhwood at
> "The rules are simple: The ball is round. The game lasts 90  
> minutes. All the
> rest is just philosophy."

More information about the macports-users mailing list