gdc & g95 error: indirect jmp without `*'

Casey Rodarmor casey at
Mon Sep 17 21:22:55 PDT 2007

Hi everybody,

I can't seem to compile anything with g95 @0.90_1  and gdc 0.24. I get
the same error message for both. I am running OS X 10.4.10 on a
MacBook Pro. I haven't installed any gcc aside from Apple's.

Here is the output when I try to compile a hello world with f95:

    casey at agave [~/Desktop] g95 hello.f95
    /var/tmp//cc6OFGZh.s:59:indirect jmp without `*'
    /var/tmp//cc6OFGZh.s:78:indirect jmp without `*'
    /var/tmp//cc6OFGZh.s:97:indirect jmp without `*'
    /var/tmp//cc6OFGZh.s:112:indirect jmp without `*'

I can then use g95 to compile but not assemble using the -S flag, and
then change all the instances of 'jmp %eax' to 'jmp *%eax' in the .s
file. When I run it on the modified .s, it produces a working program.
I guess that either the compiler is giving bad output, or the
assembler is complaining unnecessarily. Any ideas? Would it be worth
trying to install a new gcc through macports?

Thanks for reading!

Casey Rodarmor

More information about the macports-users mailing list