Problem with MacPorts on OS X Leopard

Unnsse Khan untzkhan at
Sun Aug 3 17:16:06 PDT 2008

When I tried issuing "sudo port -v selfupdate" from the command line,  
it stated that I already had the most up to date version...

Mr. Blackburn's suggestion worked like a charm (and I didn't have to  
replace the config files from local10.4 back up dir).

readline and ruby are now installed correctly as a result of the fixed  
Mac Ports binary but when I tried installing subversion:

sudo install subversion

I received this error message:

--->  Building sqlite3 with target all
Error: Target returned: shell command " cd "/opt/ 
.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.9" &&  
gnumake all " returned error 2
Command output: sed -e s/--VERS--/3.5.9/ ./src/ | \
	sed -e s/--VERSION-NUMBER--/3005009/ >sqlite3.h
/usr/bin/gcc-4.0 -O2 -o mkkeywordhash  ./tool/mkkeywordhash.c
./mkkeywordhash >keywordhash.h
/usr/bin/gcc-4.0 -O2 -o lemon ./tool/lemon.c
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon  parse.y
mv parse.h parse.h.temp
f ./addopcodes.awk parse.h.temp >parse.h
/bin/sh: f: command not found
gnumake: [parse.c] Error 127 (ignored)
cat parse.h ./src/vdbe.c |  -f ./mkopcodeh.awk >opcodes.h
/bin/sh: -f: command not found
cat: stdout: Broken pipe
gnumake: *** [opcodes.h] Error 127

Error: The following dependencies failed to build: apr-util sqlite3  
cyrus-sasl2 neon serf
Error: Status 1 encountered during processing.

Thanks again,


On Aug 3, 2008, at 4:43 PM, Rainer Müller wrote:

> Mark Hattam wrote:
>> So why doesn't MacPorts self-update itself with these "many" bug
>> fixes when you do
>> sudo port -v selfupdate
>> or are these bug fixes not proven?
> 1.6.0 is the latest release, trunk is the unreleased development  
> version.
> Rainer
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list