Having a pretty rough time getting php5 installed

Scott Haneda talklists at newgeo.com
Sat Aug 9 12:12:19 PDT 2008

> I would recommend to use everything from MacPorts. We have a HOWTO  
> for setting up Apache, MySQL and PHP:
> <http://trac.macports.org/wiki/howto/MAMP>

Not going to well, apache2 went in fine, mysql seems to now have gone  
in with a clean being done first.  I ran the load of the launcd file,  
that was fine, then when I run:
sudo mysql5 mysql_install_db5
ERROR 2002 (HY000): Can't connect to local MySQL server through socket  
'/opt/local/var/run/mysql5/mysqld.sock' (2)
So, of course, I can not start it either
me at me:/opt/local/bin/ $sudo /opt/local/bin/mysqld_safe5 &
[1] 67824
me at me:/opt/local/bin/ $Starting mysqld daemon with databases from /opt/ 
STOPPING server from pid file /opt/local/var/db/mysql5/me.local.pid
080809 12:10:06  mysqld ended
So I move on, trying to get php5 going:
sudo port clean php5
sudo port install php5 +apache2 +mysql5 +pear +imap +sqlite +tidy
* How do I get sqlite support in php5?
... fetches most everything ... then ...
Error: Target org.macports.fetch returned:

                     You have an Apple X11 installation already.
                         MacPorts will not overwrite it.

                     If you wish to use Apple X11,
                         install the X11SDK included with Xcode tools.

                     If you really want to use XFree86 instead,
                         please move it aside first :

                             sudo mv /usr/X11R6 /usr/X11R6.apple

Error: The following dependencies failed to build: gd2 XFree86  
autoconf help2man p5-locale-gettext perl5.8 m4 automake fontconfig  
jpeg libpng libtool libmcrypt libxml2 libxslt mhash tidy tiff
Error: Status 1 encountered during processing.

talklists at newgeo.com

More information about the macports-users mailing list