Having a pretty rough time getting php5 installed

Scott Haneda talklists at newgeo.com
Sat Aug 9 16:14:29 PDT 2008

>> Not going to well, apache2 went in fine, mysql seems to now have gone
>> in with a clean being done first.  I ran the load of the launcd file,
>> that was fine, then when I run:
>> sudo mysql5 mysql_install_db5
>> ERROR 2002 (HY000): Can't connect to local MySQL server through  
>> socket
>> '/opt/local/var/run/mysql5/mysqld.sock' (2)
> Is it possible that this instance is conflicting the instance that you
> installed earlier?

port uninstall mysql5 and reinstall worked, but I have some comments,  
as the docs are a little off, which is why this was not working for me  
I think...

Specifically this page http://trac.macports.org/wiki/howto/MAMP

This will not work: sudo mysql5 mysql_install_db5
This will not work: sudo mysql_install_db5

Sending in the user of mysql will work, so the correct command is:
sudo -u mysql mysql_install_db5

On my system I do not have local/var/log
sudo chown -R mysql:mysql /opt/local/var/log/mysql5/
So that will error, maybe there should be a log dir, not sure, not  
sure what would make it.  The docs here at least do tell you maybe try  
another set of permission commands

* what are these poops all over the place? .turd_mysql5

All the docs use a strange "–", so copy and paste will fail, such as  
ps –ax | grep mysql does not work, but of course ps -ax | grep mysql  
does work.  Small detail, but to someone who does not know, they would  
get stuck on that.

This command is going to need sudo, fixing of the dash, removal of the  
mysqladmin5 –u root –p password <new-password>

So, the correct usage is: mysqladmin -u root password NEWPASSWORD

I think that covers it, I will post a separate email about my.cnf
talklists at newgeo.com

More information about the macports-users mailing list