I cannot build gcc3.3 or 3.4

Da Zheng zhengda1936 at gmail.com
Mon Aug 25 10:36:41 PDT 2008

Thank you.
I like to give a try. As long as I can install Hurd in the virtual 
machine, I don't care which one I use:-)

Zheng Da

Anthony Agelastos wrote:
> Hello,
> Not to veer off-topic, but if you were willing to try Q, why don't you 
> give VirtualBox a try; it is available at the following website.
> http://www.virtualbox.org/
> I've never used it, but I've heard good things about it.
> On Aug 25, 2008, at 12:45 PM, Ryan Schmidt wrote:
>> On Aug 25, 2008, at 01:44, Da Zheng wrote:
>>> Ryan Schmidt wrote:
>>>> On Aug 24, 2008, at 13:10, Da Zheng wrote:
>>>>> I run "sudo port install apple-gcc33", but get another error:
>>>>> /usr/bin/gcc-4.0  tclAppInit.o
>>>>> -L/opt/local/var/macports/build/
>>>>> _opt_local_var_macports_sources_rsync.macports.org_release_ports_lan
>>>>> g_apple-gcc33/work/build/tcl/unix
>>>>> -ltcl8.0  -lc \
>>>>>         -o tclsh
>>>>> make[1]: *** No rule to make target `all'.  Stop.
>>>>> make: *** [all-expect] Error 2
>>>>> It's too bad if gcc 3.x cannot be built in Leopard.
>>>> It's not really too bad; GCC 3 is obsolete and shouldn't really be
>>>> used anymore.
>>>>> Actually what I really want is to build qemu.
>>>> Right. So qemu should be made to work with GCC 4. And the qemu
>>>> port already has tons of patches to make it use GCC 4, though
>>>> they're only used on Intel on Leopard and Tiger. It still uses GCC
>>>> 3 on PowerPC on Leopard and Tiger. Are you on PowerPC or Intel?
>>>> I don't have Leopard with me at the moment but I can test on some
>>>> Leopard systems in a few days.
>>>> Unfortunately the qemu port has no maintainer. Someone who is
>>>> interested in the qemu software should adopt the port and fix any
>>>> issues.
>>> I use Intel. Could you tell where I can get the patches?
>>> I find a website, but it has only the patch for the old qemu.
>>> I tried Q, a Mac port of qemu, but Hurd doesn't work well in it.
>> The patches are in the port. Typing "sudo port install qemu" is all
>> you should need to do to get them to be used. So I don't know why
>> it's not working for you. I will test with Leopard on Intel later and
>> let you know what I find.
>> _______________________________________________
>> macports-users mailing list
>> macports-users at lists.macosforge.org
>> http://lists.macosforge.org/mailman/listinfo.cgi/macports-users

More information about the macports-users mailing list