boost 1.35.0 build fails

Ryan Schmidt ryandesign at
Tue May 13 00:09:51 PDT 2008

On May 13, 2008, at 12:29 AM, Igor Mikushkin wrote:

> 2008/5/13 Ryan Schmidt:
>> On May 12, 2008, at 7:33 AM, Igor Mikushkin wrote:
>>> When I try to install boost I get this error:
>>> --->  Building boost with target all
>>> Error: Target returned: shell command " cd
>>> "/opt/local/var/macports/build/ 
>>> _opt_local_var_macports_sources_rsync.macports.org_release_ports_dev 
>>> el_boost/work/boost_1_35_0"
>>> && gmake all " returned error 2
>>> Command output: Makefile:2: *** missing separator.  Stop.
>>> First 3 lines of Makefile:
>>> BJAM=./tools/jam/src/
>>> ...skipped bjam for lack of ...
>>> ...failed updating 1 target.../bjam
>>> (I didn't have installed BJAM before boost installation)
>> The boost port says it depends on the boost-jam port. So just to  
>> make sure:
>> the boost-jam port did get installed for you automatically, yes?
> Yes, boost-jam did get installed automatically as a dependency of
> boost libraries.
>>> After manual ./configure all is OK.
>> Explain. You went into the worksrcdir and ran "./configure" and  
>> then tried
>> "sudo port install boost" again and it worked? Or what?
> Yes, I looked at a makefile, then decided to run configure script.
> After that "sudo port install boost" worked properly.
>>> Is this a bug?
>> Hard to know at this point. What version of Mac OS X, Xcode, and  
>> MacPorts
>> do you have, and on what processor? Someone with a similar  
>> configuration
>> could try it out and see if we can reproduce the problem.
> Configuration:
> - MacOS X 10.5.2
> - XCode 3.0
> - MacPorts 1.600
> - Processor: PPC

Ok. I can reproduce the issue on Mac OS X 10.5.2, Xcode 3.1 (iPhone  
SDK beta 5), MacPorts 1.7 (trunk r36691), Intel Core 2 Duo.

The problem is likely the very common one that affects Leopard users,  
described here: 

The problem occurs when you request to install one port, but this  
causes another port to first be installed as a dependency. The  
environment variables don't get properly reset between finishing  
installing one port and beginning to install the next one. This may  
be due to a bug in Leopard's tcl, we're not sure yet. We don't have a  
solution to this problem right now, but the workaround is to clean  
the port work area and just request the install again. It works the  
second time.

sudo port clean --work boost
sudo port install boost

More information about the macports-users mailing list