Another getting started thread

Ryan Schmidt ryandesign at
Sun Sep 14 19:10:56 PDT 2008

On Sep 14, 2008, at 1:37 PM, David I wrote:

> Okay.  I figured it out, I was double clicking the port file in the
> bin folder, which made everything a port command.

Oh! Yes that would do it too. :) Glad you figured it out.

> I ran the .profile
> command, closed the window, ran selfupdate, it all worked.  I try to
> install rrgbis and it works fine, but then I get this:
> ld: cycle in dylib re-exports with /usr/X11/lib/libGL.dylib
> collect2: ld returned 1 exit status
> make[3]: *** [] Error 1
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all] Error 2
> make: *** [ftgl] Error 2
> Error: Status 1 encountered during processing.
> This appears to be the second error from this page:
> Unfortunately, I don't understand what to do for the fix, because I
> don't really know what a platform darwin 9 block is, and I wouldn't
> know where to add the code in it if it bit me in the ass.

That does sound like one of the usual Leopard issues, however I have  
no problem installing rrgbis on Mac OS X 10.5.4 PowerPC with Xcode  
3.1 and MacPorts built from trunk. Is your OS and Xcode up to date?  
Is it really the rrgbis port that's issuing this error message, or is  
it one of rrgbis' dependencies? You snipped the part of the output  
that would have told us. Still, all of its dependencies clearly also  
built for me on Leopard so I'm not really sure what's wrong. Are you  
using Apple's X11 (I am) or Xquartz?

> PS thank you for all your great help!

No problem! P.S: Don't forget to Reply All so your replies go to the  
list, not just to me; others besides me might be able to help too.

More information about the macports-users mailing list