failed to build dia

Normen Müller normen.mueller at
Mon Sep 29 08:52:18 PDT 2008

Anders F Björklund wrote:
> Normen Müller wrote:
>>> The building of GTK+ 2.14 has been fixed in revision 2.
>>> You will still get activation problems with conflicts
>>> against the "gail" port, but that is expected since
>>> gail has now been included in gtk2. This is the same as:
>>> (for +quartz)
>>> --anders
>> Don't want to get on your nerves, but what does that mean.  I still 
>> can't install dia and gtk 2.4, respectively?
>> Is there any other choice to get dia installed?  If yes, could please 
>> provide me with some installation instructions?
> It only means that when you install gtk2, you'll get a:
> Error: port activate failed: Image error: 
> /opt/local/include/gail-1.0/gail/gailwidget.h is being used by the 
> active gail port.  Please deactivate this port first, or use the -f flag 
> to force the activation.
> And then you'll need to do an extra step like this:
> sudo port -f activate gtk2 @2.14.3_2+x11
> That'll move the old gail inside, and then it's done.
> Eventually the old gail port will get deleted/removed.
> --anders
Hmmm, I did the following:

# port install gtk2
--->  Activating gtk2 2.14.3_2+x11
Error: Target org.macports.activate returned: Image error: Another version of this port (gtk2 @2.14.3_1+x11) is already active.
Error: Status 1 encountered during processing.

# port uninstall gtk2 @2.14.3_1+x11
--->  Deactivating gtk2 2.14.3_1+x11
--->  Uninstalling gtk2 2.14.3_1+x11

# port install gtk2
--->  Activating gtk2 2.14.3_2+x11
--->  Cleaning gtk2

and that just went through fine, without any complains.

Then I searched for gail

# port installed | grep gail

without any hit.

Then I tried to install dia again:

# port install dia
--->  Building dia with target all
--->  Staging dia into destroot
--->  Installing dia 0.96.1_0
--->  Activating dia 0.96.1_0
--->  Cleaning dia


Once again: Thank you!!!


Normen Müller

More information about the macports-users mailing list