Libtheora doesn't build

Gonzalo Abella abellagonzalo at
Mon Apr 20 10:47:01 PDT 2009

I'm a new Macports user and I have some problems installing libtheora
library needed for Gimp and for ffmpeg. I have Darwin 8.11 and MacOS

ip_wless_escet_52:~ gon$ sudo port install libtheora
--->  Building libtheora
Error: Target returned: shell command " cd
&& make all " returned error 2
Command output: make  all-recursive
Making all in lib
if /bin/sh ../libtool --tag=CC --mode=compile /usr/bin/gcc-4.0
-DHAVE_CONFIG_H -I. -I. -I.. -I../include  -I/opt/local/include
-I/opt/local/include   -Wall -Wno-parentheses -O3 -fforce-addr
-fomit-frame-pointer -finline-functions -funroll-loops -O2 -MT dsp_mmx.lo
-MD -MP -MF ".deps/dsp_mmx.Tpo" -c -o dsp_mmx.lo `test -f
'enc/x86_32/dsp_mmx.c' || echo './'`enc/x86_32/dsp_mmx.c; \
then mv -f ".deps/dsp_mmx.Tpo" ".deps/dsp_mmx.Plo"; else rm -f
".deps/dsp_mmx.Tpo"; exit 1; fi
 /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I../include
-I/opt/local/include -I/opt/local/include -Wall -Wno-parentheses -O3
-fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops -O2 -MT
dsp_mmx.lo -MD -MP -MF .deps/dsp_mmx.Tpo -c enc/x86_32/dsp_mmx.c
 -fno-common -DPIC -o .libs/dsp_mmx.o
/var/tmp//ccXbfBrr.s:739:no such 386 instruction: `movsx'
/var/tmp//ccXbfBrr.s:789:no such 386 instruction: `movsx'
/var/tmp//ccXbfBrr.s:853:no such 386 instruction: `movsx'
make[2]: *** [dsp_mmx.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

It is a very strange error I've ever seen. I have tried to install it with
the command 'port install libtheora + universal', but with same result. In
google I find nothing.

Any ideas?

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list