Libtheora doesn't build

Gonzalo Abella abellagonzalo at
Thu Apr 23 16:05:07 PDT 2009

Instalando Gimp:  - Revisar que la version de xcode sea la 2.5, sino falla
libtheora.- Instalar gtk-doc o meterlo como dependencia. El problema lo dio
instalando pango.

Perfect!! I have Gimp installed and running!! The problem was that i had
Xcode 2.2.1. It would be a good idea to print an advise.

I also had another little problem installing Gimp. Pango failed to build
because i didn't have installed gtk-doc. I solve it, installing it manually
xD. Apart that, everything ok.


2009/4/21 Ryan Schmidt <ryandesign at>

> On Apr 20, 2009, at 12:47, Gonzalo Abella wrote:
>  I'm a new Macports user and I have some problems installing libtheora
>> library needed for Gimp and for ffmpeg. I have Darwin 8.11 and MacOS
>> 10.4.11.
>> ip_wless_escet_52:~ gon$ sudo port install libtheora
>> Password:
>> --->  Building libtheora
>> Error: Target returned: shell command " cd
>> "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_libtheora/work/libtheora-1.0"
>> && make all " returned error 2
>> Command output: make  all-recursive
>> Making all in lib
>> if /bin/sh ../libtool --tag=CC --mode=compile /usr/bin/gcc-4.0
>> -DHAVE_CONFIG_H -I. -I. -I.. -I../include  -I/opt/local/include
>> -I/opt/local/include   -Wall -Wno-parentheses -O3 -fforce-addr
>> -fomit-frame-pointer -finline-functions -funroll-loops -O2 -MT dsp_mmx.lo
>> -MD -MP -MF ".deps/dsp_mmx.Tpo" -c -o dsp_mmx.lo `test -f
>> 'enc/x86_32/dsp_mmx.c' || echo './'`enc/x86_32/dsp_mmx.c; \
>> then mv -f ".deps/dsp_mmx.Tpo" ".deps/dsp_mmx.Plo"; else rm -f
>> ".deps/dsp_mmx.Tpo"; exit 1; fi
>>  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I../include
>> -I/opt/local/include -I/opt/local/include -Wall -Wno-parentheses -O3
>> -fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops -O2 -MT
>> dsp_mmx.lo -MD -MP -MF .deps/dsp_mmx.Tpo -c enc/x86_32/dsp_mmx.c
>>  -fno-common -DPIC -o .libs/dsp_mmx.o
>> /var/tmp//ccXbfBrr.s:739:no such 386 instruction: `movsx'
>> /var/tmp//ccXbfBrr.s:789:no such 386 instruction: `movsx'
>> /var/tmp//ccXbfBrr.s:853:no such 386 instruction: `movsx'
>> make[2]: *** [dsp_mmx.lo] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
>> Error: Status 1 encountered during processing.
>> It is a very strange error I've ever seen. I have tried to install it with
>> the command 'port install libtheora + universal', but with same result. In
>> google I find nothing.
> Welcome to MacPorts!
> I did find some occurrences of this error in a Google search. One suggested
> that you might be using an old version of Xcode. If you do not have Xcode
> 2.5, upgrade to Xcode 2.5 and try again, making sure to clean the port first
> (sudo port clean libtheora). Let us know if that fixes it; if it does, we
> can modify the port to print a warning if Xcode < 2.5 is used.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list