gnome-doc-utils is missing db2omf - SOLVED

Ryan Schmidt ryandesign at
Thu Feb 5 18:08:26 PST 2009

On Feb 5, 2009, at 16:04, Michael Crawford wrote:

> A Perl CPAN package called LWP tries to install a command called
> /usr/bin/HEAD - uppercase "HEAD", but because HFS+ is by default
> case-insensitive, it ends up overwriting the lowercase /usr/bin/head.
> HFS+ preserves filename cases, but you can't have to files with the
> same spelling in the same directory, even if their cases are
> different!

Yes... I ran into this too, probably 7 years ago, but it should have  
been fixed in LWP a very long time ago. I believe it doesn't install  
HEAD by default now.

> LWP is some kind of automated HTTP client; I installed it a while back
> to enable the generation of RSS feeds for my blog, which is just a
> bunch of static HTML files, rather than being implemented by some kind
> of web application software.  I have a Perl script that downloads my
> homepage and looks for new blog entries in it, then generates my RSS.
> I upload the RSS file to my site with scp.

If you want LWP, MacPorts provides it in the port p5-libwww-perl. Of  
course MacPorts installs into its own prefix (usually /opt/local) so  
it won't overwrite head or anything else in /usr/bin.

> Both Brad Rice and Ken Williams recommend getting the /usr/bin/head
> from your OS X install DVD, but what I did was after installing the
> coreutils port, I copied /opt/local/bin/ghead to /usr/bin/head.  It
> seems to work fine now.

I would recommend following Brad and Ken's advice instead. ghead is  
GNU head, while the head that was on your operating system before was  
BSD head. They may not be entirely compatible.

More information about the macports-users mailing list