Error when upgrading port: Errno architecture does not match executable architecture

Ryan Schmidt ryandesign at
Thu Jul 9 12:49:27 PDT 2009

On Jul 8, 2009, at 22:29, jsmorris wrote:

> I tried Ryan's suggestion, but it did not work.  I still got the same
> error message.  The perl port seems to build just fine.  Is this a
> problem with this version of Perl?  I even uninstalled my perl5.8 port
> and re-installed it, but still the same error message.

What port provides /opt/local/lib/perl5/site_perl/5.8.8/ on  
your system? Type

port provides /opt/local/lib/perl5/site_perl/5.8.8/

to find out. That port needs to be rebuilt (sudo port -nf upgrade).

If /opt/local/lib/perl5/site_perl/5.8.8/ does not belong to a  
port, how did it get there? Did you install it manually, or use CPAN  
to install Perl modules? If so, you may need to remove it manually or  
with CPAN. You should only install Perl modules (or anything else in / 
opt/local) using MacPorts.

On my system I don't have that file; I have /opt/local/lib/ 
perl5/5.8.9/darwin-2level/ and it is provided by the perl5.8  

Which brings up the point that the current version of perl in  
MacPorts is 5.8.9 so I don't know why anything 5.8.8 is still showing  
up on your system. Are your ports up to date? (sudo port sync && sudo  
port upgrade outdated)

More information about the macports-users mailing list