gmt error/known problem with netcdf?

Gwen Barnes gwen.barnes at
Sat Jul 18 18:37:33 PDT 2009

Hey folks,

When I try to run any GMT command, I get the following error:

dyld: Symbol not found: _H5P_CLS_FILE_ACCESS_g
  Referenced from: /opt/local/lib/libnetcdf.6.dylib
  Expected in: dynamic lookup
Trace/BPT trap

According to the following website, there is a very similar error that is a
known problem with netcdf:

The solution they present there is "This is caused by the -O2 parameter in
the build. Set CFLAGS to -g and try again." I have changed all the -O2 flags
to -g in /opt/local/var/macports/sources/  Then I ran

sudo port uninstall gmt
sudo port uninstall netcdf
sudo port install netcdf
sudo port install gmt

I got no errors on the install, but the GMT commands are still giving me the
same error.  Can anyone help me get my GMT running again?  Thanks.

mac OSX 10.5.7
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list