Fontconfig broken

Adam Dershowitz dersh at
Mon May 4 15:57:52 PDT 2009

On May 4, 2009, at 2:03 PM, Bryan Blackburn wrote:

> On Mon, May 04, 2009 at 01:44:48PM -0700, Adam Dershowitz said:
>> I seem to have an odd problem of a port that is "sort of installed  
>> and
>> sort of not".
>> I see that gd2 is outdated, so I did a port sync and port upgrade
>> outdated.
>> At which point I got this:
>> Error: No port fontconfig found.
>> Error: Dependency 'fontconfig' not found.
>> Error: Unable to upgrade port: 1
>> If I try to look for the port I get this:
>>> port info fontconfig
>> Error: Port fontconfig not found
> You probably sync'd when portindex failed to get fontconfig due to  
> some
> X11-based changes; try a sync again as fontconfig was fixed in  
> r50581 and
> portindex was successful in r50583.

Thanks.  I had tried to sync a few times, with the same results,  
before I sent the email.
But, after I got your email I tried again, and sure enough it worked  
just fine.

Thanks for the help.

> Bryan
>> But if I do this:
>>> port installed fontconfig
>> The following ports are currently installed:
>>  fontconfig @2.6.0_1+macosx
>>  fontconfig @2.6.0_2+macosx (active)
>> I see that I actually have the port installed and active.
>> So it seems that it is there, but macports can not find it.   
>> Something is
>> clearly broken.
>> Any idea what, or what I can do about it?
>> Thanks,
>> --Adam
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list