building py-pyobjc2 gives $MACOSX_DEPLOYMENT_TARGET mismatch

Ryan Schmidt ryandesign at
Thu May 28 10:51:11 PDT 2009

On May 28, 2009, at 11:06, Harry van der Wolf wrote:

> I have the following settings in my  macports.conf:
> universal_target        10.4
> # the SDK "sysroot" to use
> universal_sysroot       /Developer/SDKs/MacOSX10.4u.sdk
> # machine architectures
> universal_archs         ppc i386
> I'm now trying to build py-game which needs py-pyobjc2 as  
> dependency. Universal didn't work, but that's no problem as I only  
> need this one on my own macbook. So, I tried to built py-game with - 
> universal.
> All went fine to py-pyobjc2 which menations  
> "distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET  
> mismatch: now "10.5" but "10.4" during configure".
> I did a port clean of py-pyobjc2 and changed the 10.4 setting to  
> 10.5 and tried to build py-pyobjc2 again. The same error still  
> occurred, so I changed it back to 10.4.
> What can I do about this?

My understanding is that PyObjC 2.x requires Mac OS X 10.5.x or  
greater (thus the 10.5 or greater SDK and MACOSX_DEPLOYMENT_TARGET  
set to 10.5 or greater), while PyObjC 1.x requires Mac OS X 10.4.x or  

More information about the macports-users mailing list