Fwd: building py-pyobjc2 gives $MACOSX_DEPLOYMENT_TARGET mismatch

Harry van der Wolf hvdwolf at gmail.com
Thu May 28 11:30:55 PDT 2009

now to the macports group.


---------- Forwarded message ----------
From: Harry van der Wolf <hvdwolf at gmail.com>
Date: 2009/5/28
Subject: Re: building py-pyobjc2 gives $MACOSX_DEPLOYMENT_TARGET mismatch
To: Ryan Schmidt <ryandesign at macports.org>

2009/5/28 Ryan Schmidt <ryandesign at macports.org>

On May 28, 2009, at 11:06, Harry van der Wolf wrote:
>  I have the following settings in my  macports.conf:
>> universal_target        10.4
>> # the SDK "sysroot" to use
>> universal_sysroot       /Developer/SDKs/MacOSX10.4u.sdk
>> # machine architectures
>> universal_archs         ppc i386
>> I'm now trying to build py-game which needs py-pyobjc2 as dependency.
>> Universal didn't work, but that's no problem as I only need this one on my
>> own macbook. So, I tried to built py-game with -universal.
>> All went fine to py-pyobjc2 which menations
>> "distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET
>> mismatch: now "10.5" but "10.4" during configure".
>> I did a port clean of py-pyobjc2 and changed the 10.4 setting to 10.5 and
>> tried to build py-pyobjc2 again. The same error still occurred, so I changed
>> it back to 10.4.
>> What can I do about this?
> My understanding is that PyObjC 2.x requires Mac OS X 10.5.x or greater
> (thus the 10.5 or greater SDK and MACOSX_DEPLOYMENT_TARGET set to 10.5 or
> greater), while PyObjC 1.x requires Mac OS X 10.4.x or earlier.
I'm affraid you are right. I had already seen that the Portfile mentioned:
if {${os.major} < 9} {
    pre-fetch {
        return -code error "PyObjC 2.0 requires Mac OS X 10.5"

But being ON 10.5 I assumed it would work.
So I also tried to install the py-pyobjc version:
sudo port install py-pyobjc
--->  Computing dependencies for py-pyobjc
--->  Fetching py-pyobjc
Error: Target org.macports.fetch returned: PyObjC 1.4 is for Mac OS X 10.4
and lower. On 10.5, use py-pyobjc2 instead.
Error: Status 1 encountered during processing.

As that one "sensed" it was on 10.5 instead of 10.4, I (again) assumed that
objc2 could also "sense" that it was on 10.5 despite the deployment setting
and the 10.4u.sdk.  So I switched back to py-pyobjc2.

On your reply I also tried to change the macports.conf and set the
deployment target to 10.5 and the SDK to 10.5 as well.
But again: "distutils.errors.DistutilsPlatformError:
$MACOSX_DEPLOYMENT_TARGET mismatch: now "10.5" but "10.4" during configure"

So, I'm affraid I'm in some dead-lock.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20090528/9bc60445/attachment.html>

More information about the macports-users mailing list