no library dependencies

David Cake dave at
Sun Nov 15 22:50:01 PST 2009

At 10:42 AM +0100 13/11/09, Raphael Straub wrote:
>David Cake wrote:
>>At 7:19 PM +0100 11/11/09, Raphael Straub wrote:
>>>The easiest way to do this is to use the "macho_standalone" script 
>>>on a copy of the dvdauthor and ffmpeg binaries from MacPorts that 
>>>you put inside an application bundle, see
>>	I tried going this route.
>>	For some reason the py26-macholib port doesn't install the 
>>command line tools.
>Well, they should be there. Maybe they are not where you expect them to be:
>>  port contents py26-macholib | grep macho_standalone

	Thanks for that. Though not exactly a useful place to put 
them, unlikely to be in anyones path.

>Please try to use this version. It works for me on Mac OS X 10.5 PPC.

	Tried - exactly the same error as the various other installed 
versions, so Macholib apparently just doesn't work on 10.6.
	I had a quick look at the issue and couldn't see an easy fix, 
so I am not sure how to proceed other than hoping the maintainer 
fixes it. I can't find anywhere to report bugs for this (or any other 
MacPython stuff), so I'm rather at a loss here.

>>	So I reverted to py-macholib, which installed python 2.4, but 
>>did install the macho command line tools. Only, that  was missing a 
>>dependency to modulegraph.... and ended up with a varient of the 
>>same error I got with 2.6
>I'll file a ticket for the missing modulegraph dependency.


More information about the macports-users mailing list