Problems compiling Freetype

Laurent Daudelin laurent.daudelin at
Tue Nov 17 13:15:44 PST 2009

I've been trying to compile podofo to bundle into a project I'm working on. Then, I was caught into some dependency problems. Podofo depends on a few libraries. The problem is compounded by the fact that I have to compile all the libraries tri-fat, ppc, 32bits Intel and 64bits Intel.

Since I wanted to package the libs with my app as I cannot assume that all users will have MacPorts installed, I tried to use the static versions of the resulting libraries. However, FontConfig will give me a missing symbol error when I try to link it to my project. So, I had to rely on the dynamic versions of the libs. Then, I had to face the problem where Apple changed the segment header of the libs under 10.6 to make it compressed or was getting the dreaded "unknown required load command 0x80000022" on a 10.5 machine. By adding '-mmacosx-version-min=10.5' to the C flags, I was able to compile FontConfig correctly and don't have the error anymore. Now, I'm having the same problem with Freetype. I did the same thing than for FontConfig. I even went step by step to check that after the configure step, the C flags were correctly generated and they were. However, when I build it, it just seems to ignore the C flags because I still have the same error. I know that MacPort is not able to cross compile but I've been able to do it, except in the case of Freetype. Is this a known issue with Freetype, ignoring C flags?


Laurent Daudelin
Logiciels Nemesys Software              				laurent.daudelin at
Photo Gallery Store:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list