apache2 fails to build

Lucien GENTIS lucien.gentis at medecine.uhp-nancy.fr
Thu Nov 19 01:55:50 PST 2009

Le 18 nov. 09 à 18:53, Joshua Root a écrit :

> On 2009-11-18 23:35, Lucien Gentis wrote:
>> So, I verified variants installed, and all ports whom apache2  
>> depends are build with universal variant.
>> But there seems to be a problem with libaprutil :
>> command "file /opt/local/lib/libaprutil-" only returns :
>> /opt/local/lib/libaprutil- Mach-O 64-bit dynamically  
>> linked shared library x86_64
>> So, even if apr-util is installed with "universal" variant, it  
>> supports only x86_64 architecture, and when I try to install  
>> apache2, it doesn't find certain symbols in libaprutil for i386  
>> architecture.
> You appear to have found a bug in apr-util. Please file a ticket in  
> trac.


>> But, since my iMac has a x86_64 architecture, I don't need apache2  
>> build for i386 ; so I edited /opt/local/etc/macports/macports.conf  
>> and changed "universal_archs                x86_64 i386" to  
>> "universal_archs                x86_64", and it worked.
> Why are you using +universal if you only need a single-architecture
> build? Changing universal_archs to contain only one architecture makes
> no sense.

In fact, I didn't explicitly specify any variant ; I simply tried to  
build apache2 port via command "sudo port install apache2".
And it failed because apr-util was build for x86_64 architecture only,  
and apache2 tried to build for both x86_64 and i386 architectures ; so  
it didn't find i386 symbols in libaprutil.

Changing universal_archs to contain only one architecture is the only  
way I found to build apache2 port (see below)

>> But this doesn't explain why apr-util isn't installed for i386  
>> architecture, even with "universal" variant. (how does it work on  
>> i386 machines ?)
> If you install without +universal, ports are built for $build_arch.  
> See
> <http://guide.macports.org/chunked/internals.configuration-files.html#internals.configuration-files.macports-conf 
> >.
> - Josh

So I tried to uninstall apache2 and apr-util, set $buil-arch to x86_64  
in /opt/local/etc/macports/macports.conf, but even with that  
modification, apache2 seems to try to build itself for both x86_64 and  
i386 architectures because I get the same error about "Undefined  
symbols for architecture i386"

And if I comment build_conf line in /opt/local/etc/macports/ 
macports.conf, and set universal_archs to x86_64, apache2 buils with  
success via command "port install apache2".

lucien.gentis at medecine.uhp-nancy.fr
Faculté de Médecine de Nancy
Service informatique réseau et Télécommunications
Tél 03 83 68 30 62

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20091119/ea29f4bd/attachment.html>

More information about the macports-users mailing list