Link issue

Adam Dershowitz dersh at
Wed Oct 28 16:21:30 PDT 2009

I am not really sure if this is a Macports issue, a specific port  
issue, or something else entirely, but I figured I would ask here,  
because maybe someone can help.

I just upgraded to a new Mac and also upgraded from 10.5 to 10.6.  I  
did a reinstall of macports and my ports, as instructed on the  
migration page.  One of the ports that I re-installed is qt4-mac.
The problem is now when I try to build sqliteman (an application that  
uses qt4, but that doesn't yet have a port) I get a link error:

Linking CXX executable sqliteman
ld: library not found for -lcrt1.10.6.o
collect2: ld returned 1 exit status
make[2]: *** [sqliteman/sqliteman] Error 1
make[1]: *** [sqliteman/CMakeFiles/sqliteman.dir/all] Error 2
make: *** [all] Error 2

Now, I have found crt1.10.6.o in /usr/lib.  So it seems that something  
is wrong in my search paths.  I also tried doing this before my build:

but I got the same error.  So it seems that for some reason some  
combination of cmake, make and ld are not searching in the correct  
location.  I was able to go back and look at my old machine and didn't  
see anything in PATH or LIBRARY_PATH about /usr/lib either, so I am  
not sure where this path should be indicated?  Is it set in an  
environment variable, in qt, in cmake, in macports?
Is something wrong with Macports, qt4, cmake, XCode (I did upgrade  
that to the newest as well), my .profile, something specific to  

It clearly is something that recently changed, but that could be going  
to 10.6, or a new install of macports, or something else.  The one  
thing that did not change is that I am actually using the identical  
source code for sqliteman.

I am somewhat stumped, so figured I would ask.

Thanks for any suggestions,


More information about the macports-users mailing list