can't build a native gnucash

Ryan Schmidt ryandesign at
Thu Sep 17 12:09:38 PDT 2009

On Sep 17, 2009, at 13:44, Brian Dunn wrote:

> On Sep 17, 2009, at 10:26 AM, Ryan Schmidt wrote:
>> On Sep 17, 2009, at 10:16, Brian Dunn wrote:
>>> I've read and tried this:
>>> But I'm still getting the following error.
>>> Some googling on the '/opt/local/bin/gsed: can't read /opt/local/ 
>>> lib/ No such file or directory' bit turned up  
>>> this ticket:
>>> So apparently somewhere in my dependencies is a port that was  
>>> built against X11.
>>> Does anyone know of a way to find out what port(s) that is so I  
>>> can rebuild with the +no_x11?
>>> I'm not interested in maintaining my MacPort's installation's  
>>> ability to build against X11. I don't use any X11 apps, so it  
>>> seems that having two MacPorts installs, like suggested in the  
>>> ticket, would be the wrong approach.
>>> Any ideas on how to ferret out the X11 culprit, or to enforce  
>>> quartzyness in all my installed ports?
>>> thanks!
>>> $ sudo port install gnucash +without_hbci
>> Try:
>> sudo port upgrade --enforce-variants gnucash +without_hbci +quartz

> Well one cant upgrade a port one can't compile,

Oh, did we change that? Maybe that changed in 1.8.0 too. I seem to  
recall it used to be possible to ask port to upgrade ports you hadn't  
yet installed.

> so instead I did
> $ port deps gnucash +without_hbci
> Full Name: gnucash @2.2.9+no_x11+without_hbci
> Build Dependencies:   libtool, lzmautils
> Library Dependencies: p5-xml-parser, glib2, gconf, guile16, slib,  
> slib-guile16, popt, libgnomeui, libgnomeprintui, libgtkhtml3,  
> libgsf, goffice, libofx, p5-finance-quote
> Extract Dependencies: lzmautils
> and then I upgraded all of those library dependencies with --enforce- 
> variants +no_x11 +quartz...
> and gnucash fails to build with the same error message.

Ok. I'm not sure what else to suggest.

More information about the macports-users mailing list