Problems installing ports

Jason DeBacker jason.debacker at
Wed Apr 21 07:43:21 PDT 2010

I was able to install MacPorts 1.8.2 without any error messages, however
when I try to install a program via the "sudo port install" command, I run
into the error "sed: command not found". Below is the output when I tried to
install qtoctave-mac:

debacker$ sudo port install qtoctave-mac


---> Computing dependencies for qtoctave-mac Configuring zlib

Error: Target org.macports.configure returned: configure failure: shell
command " cd
&& ./configure --prefix=/opt/local " returned error 127 Command output:
./configure: line 18: sed: command not found

./configure: line 19: sed: command not found

./configure: line 20: sed: command not found

./configure: line 21: sed: command not found

./configure: line 46: sed: command not found Checking for shared library

Tested /usr/bin/gcc-4.2 -w -c -O2 -arch x86_64 -fPIC ztest20297.c Tested
/usr/bin/gcc-4.2 -dynamiclib -install_name ${exec_prefix}/lib/libz..dylib
-compatibility_version -current_version -O2 -arch x86_64 -fPIC -o
ztest20297.dylib ztest20297.o

ld: malformed version number: -current_version

collect2: ld returned 1 exit status

No shared library support; try without defining CC and CFLAGS Building
static library libz.a version with /usr/bin/gcc-4.2.

Checking for off64_t... No.

Checking for fseeko... Yes.

./configure: line 263: sed: command not found Checking for unistd.h... Yes.

Checking whether to use vs[n]printf() or s[n]printf()... using s[n]printf().

Checking for snprintf() in stdio.h... Yes.

Checking for return value of snprintf()... Yes.

Checking for errno.h... Yes.

./configure: line 503: sed: command not found

./configure: line 526: sed: command not found

./configure: line 544: sed: command not found

Error: The following dependencies failed to build: octave GraphicsMagick
freetype zlib jpeg lcms tiff libiconv gperf libpng libxml2 SuiteSparse metis
arpack gcc43 gmp mpfr atlas gzip texinfo gettext expat ncurses ncursesw
lzmautils curl curl-ca-bundle perl5 perl5.8 libidn openssl pkgconfig fftw-3
fftw-3-single ftgl doxygen coreutils graphviz fontconfig gd2 autoconf
help2man p5-locale-gettext m4 automake libtool xpm xorg-libXext xorg-libX11
xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto
xorg-libXdmcp xorg-util-macros xorg-xcmiscproto xorg-xextproto
xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice
ghostscript cairo libpixman xrender xorg-renderproto libpaper pango Xft2
glib2 urw-fonts xorg-libXaw groff xorg-libXmu gsed gawk glpk gnuplot
aquaterm pdflib readline hdf5-18 szip pcre qhull cmake qrupdate qt4-mac dbus
libmng sqlite3

Error: Status 1 encountered during processing.

Before reporting a bug, first run the command again with the -d flag to get
complete output.

I am not very familiar with MacPorts or installing programs from source. It
may or may not be related, but I was unable to install MacPorts from the
disk image on the page: Despite
downloading the dmg for Snow Leopard and my computer running OSX 10.6.3, it
gives me the message that I can't install this on my computer because it's
meant for OSX 10.6. In addition, when I open Octave, I get the line:

/Applications/ line 41:
/usr/bin/sed: No such file or directory

but Octave starts up.

I'm using a MacBook Pro with Intel Core Duo. I'm running OSX 10.6.3, but the
computer had 10.5 factory installed when purchased. I may have installed
MacPorts before upgrading, but I have gone through the migration
instructions and tried deleting the whole /opt directory and reinstalling
MacPorts. Before my most recent complete installation of MacPorts, I updated
my XCode to 3.2.2 and CMake to 2.8.1 and Qt to 4.6.2 (I downloaded the whole
SDK, not just the libraries). I have also installed X11 and Octave 3.2.2
(needed to install Qtoctave).

Any help is greatly appreciated. Many thanks in advance.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list