opt/local/lib/libldap-2.3.0.dylib - Error

Joshua Root jmr at macports.org
Mon Feb 1 09:01:45 PST 2010

On 2010-2-2 03:51 , Craig Hoffman wrote:
> Hi There,
> Over the weekend, I ran "self update" then "update outdated" - it updated Apache and a few other ports.  Sorry, I can't remember which ones.  I tried to start Apache this morning and I received this error:
> httpd: Syntax error on line 119 of /opt/local/apache2/conf/httpd.conf: Cannot load /opt/local/apache2/modules/libphp5.so into server: dlopen(/opt/local/apache2/modules/libphp5.so, 10): Library not loaded: /opt/local/lib/libldap-2.3.0.dylib\n  Referenced from: /opt/local/apache2/modules/libphp5.so\n  Reason: image not found
> Any ideas on what's causing it (opt/local/lib/libldap-2.3.0.dylib) and how to fix it?

Looks like php wasn't rebuilt after openldap was updated to a new binary
incompatible version. But it looks like the php ports intend to use the
LDAP in /usr, so /opt/local/lib/libldap-2.3.0.dylib being linked against
is a bug.

- Josh

More information about the macports-users mailing list