No sound/audio in KDE4

Daniel Simon Daniel.Simon at
Fri Feb 5 02:39:40 PST 2010


Has anyone gotten a KDE4 app installed that can produce sound?  Amarok?  How did you do it?

I tried installing kdemultimedia4.  Installed properly (without kmix), but no change in sound.

Tried installing phonon directly.  Installed properly, no change in sound.


/Daniel Simon

On 2 Feb 2010, at 8.21, Daniel Simon wrote:

I've installed kdegames4 and kdeedu4 successfully (the programs all run fine) but there's no sound/audio.

In particular, trying klettres from kdeedu4 produces no sound.  On the other hand, if I go into to the qtdemo application and load the phonon test app, I do hear the test sound.  So, QT can produce sound, but KDE can't.  I've looked in the logs in, but don't see anything when I try to call a sound from a KDE app.

I installed kdegames4 and kdeedu4 roughly following this protocol:

Anyone have any suggestions?

System info:
iBook G3 500 MHz and PowerBook G4 700 MHz (compiled on PB, tested on both, same result)
OS X 10.4.11 (latest)
XCode 2.5
MacPorts-1.8.2-10.4-Tiger (after selfupdate)



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list