No sound/audio in KDE4 (SOLVED)

Daniel Simon Daniel.Simon at
Tue Feb 9 11:35:28 PST 2010


The standard install of KDE4 through MacPorts uses Qt's phonon system, which in turn uses the native QuickTime as a backend.  As it states at , if QuickTime can't play it, phonon can't play it.

The solution is to install the Xiph (ogg) QuickTime component ( to allow QuickTime to play ogg files.  Installing Perian ( wouldn't hurt, either.

There should be a note during the port install process saying that this step is necessary since much of KDE's audio is in ogg format.

Happy KDE-ing!


On 5 Feb 2010, at 13.47, Richard DeLaurell wrote:

I haven't been able to get the sound to work either.

All of the kdegames are silent.

If you do a "port search kde" you will see that all of the pertinent ports for kde 3.5 say, "No KDE sound support" in the description, so sound was obviously problematic with that version.

On the other hand, the kde 4 port descriptions do not say that.

Perhaps someone with more knowledge than me could tell us whether sound is supposed to work in kde4 or not?


MacPorts 1.8.2
Darwin 9.8.0
OS X 10.5.8
Xcode 3.1.2

On Fri, Feb 5, 2010 at 4:39 AM, Daniel Simon <Daniel.Simon at<mailto:Daniel.Simon at>> wrote:

Has anyone gotten a KDE4 app installed that can produce sound?  Amarok?  How did you do it?

I tried installing kdemultimedia4.  Installed properly (without kmix), but no change in sound.

Tried installing phonon directly.  Installed properly, no change in sound.


/Daniel Simon

On 2 Feb 2010, at 8.21, Daniel Simon wrote:

I've installed kdegames4 and kdeedu4 successfully (the programs all run fine) but there's no sound/audio.

In particular, trying klettres from kdeedu4 produces no sound.  On the other hand, if I go into to the qtdemo application and load the phonon test app, I do hear the test sound.  So, QT can produce sound, but KDE can't.  I've looked in the logs in, but don't see anything when I try to call a sound from a KDE app.

I installed kdegames4 and kdeedu4 roughly following this protocol:

Anyone have any suggestions?

System info:
iBook G3 500 MHz and PowerBook G4 700 MHz (compiled on PB, tested on both, same result)
OS X 10.4.11 (latest)
XCode 2.5
MacPorts-1.8.2-10.4-Tiger (after selfupdate)



macports-users mailing list
macports-users at<mailto:macports-users at>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list