Error installing p5-net-libidn

Ryan Schmidt ryandesign at
Thu Feb 11 17:50:01 PST 2010

On Feb 11, 2010, at 19:14, Scott Haneda wrote:

> On Feb 11, 2010, at 4:38 PM, Ryan Schmidt wrote:
>> On Feb 11, 2010, at 14:32, Scott Haneda wrote:
>>> DEBUG: Environment: CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-O2 -arch x86_64' MACOSX_DEPLOYMENT_TARGET='10.6' LIBRARY_PATH='/opt/local/lib' CXX='/usr/bin/g++-4.2' F90FLAGS='-O2 -m64' LDFLAGS='-L/opt/local/lib' FCFLAGS='-O2 -m64' OBJC='/usr/bin/gcc-4.2' INSTALL='/usr/bin/install -c' C_INCLUDE_PATH='/opt/local/include' OBJCFLAGS='-O2 -arch x86_64' FFLAGS='-O2 -m64' CC='/usr/bin/gcc-4.2'
>> You're trying to build p5-net-libidn for the architecture x86_64.
> This is a pretty clean install of 10.6, I have not done anything out of the ordinary.

Right, x86_64 is the way things build by default on 10.6, but on 10.5 and earlier, things built i386 by default.

>>> DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/work/Net-LibIDN-0.12" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor'
>>> ld: warning: in /opt/local/lib/libidn.dylib, file is not of required architecture
>> But its dependency libidn is installed for a different architecture. Rebuild libidn.
> How do I find out what installed libidn?

"port provides /opt/local/lib/libidn.dylib" shows that libidn.dylib was installed by the libidn port.

>> The only way this should have happened is if you installed libidn while running Mac OS X 10.5 or earlier, then upgraded to Mac OS X 10.6 and tried to build p5-net-libidn.
> No, I started with a clean system, downloaded developer tools, and had a clean MacPorts.
>> It could also happen if you deliberately set build_arch to, say, i386 in macports.conf before building libidn, then set it back to x86_64 afterward, but you probably wouldn't do that.
> This is what I have...
> # CPU architecture to compile for. Defaults to i386 or ppc on Mac OS X 10.5
> # and earlier, depending on the CPU type detected at runtime. On Mac OS X 10.6
> # the default is x86_64 if the CPU supports it, i386 otherwise.
> #build_arch                     i386
> I do not think I had libidn installed before I tried to install p5-net-libidn.  I was only trying to get back into the ASSP port and it's dependencies, installing that list of dependencies kicked this up.

Ok, then I can't explain why your libidn.dylib wouldn't be built x86_64. For what architecture is it built? lipo -info would tell you:

"lipo -info /opt/local/lib/libidn.dylib"

> What would be the easiest way to take all my currently installed ports and see which, if any, depend on libidn.

"port dependents libidn"

More information about the macports-users mailing list