"sudo port upgrade outdated" fills HDD

Bradley Giesbrecht brad at pixilla.com
Wed Feb 17 10:37:27 PST 2010

On Feb 17, 2010, at 10:17 AM, Sam Kuper wrote:

> On 17 February 2010 17:45, Bradley Giesbrecht <brad at pixilla.com>  
> wrote:
> On Feb 17, 2010, at 7:55 AM, Sam Kuper wrote:
> On 17 February 2010 15:33, Daniel J. Luke wrote:
> On Feb 17, 2010, at 10:23 AM, Sam Kuper wrote:
> > On 17 February 2010 14:59, Sam Kuper wrote:
> > The latter command has got as far as "---> Building boost" but  
> seems now to be stuck there and is now simply eating hard drive  
> space. I had 3.03GB free hard disk space when I ran the command, and  
> now, 20 minutes later, have only 1.09GB free and this is decreasing  
> by 0.01GB every few seconds.
> >
> > I should clarify that for the majority of the 20 minutes mentioned  
> (approx. 19 minutes), the command was stuck at "---> Building  
> boost". After around 40 minutes, with a bit over 0.7GB of HDD space  
> remaining, the command printed the line "--->  Staging boost into  
> destroot" to the Terminal. HDD space is, however, continuing to  
> decrease at about the same rate.
> Check /var/vm and see if you're just running out of RAM and  
> generating large amounts of swap.
> Thanks Daniel,
> I had to use Ctrl+C to stop "sudo port upgrade outdated" from  
> running, as it reached the point where the Finder was saying "Zero  
> KB free". Then I ran "sudo port clean boost" to get some of my HDD  
> back! It immediately went up to 2.33GB free.
> Now, I've just had a look in /var/vm . It contains a dozen swapfiles  
> of 67108864 bytes each, plus a sleepimage file of 2147483648 bytes.  
> I've no idea whether this is normal or not, though: I've never  
> looked in that directory before.
> Also, I don't see a way to tell whether the swapfiles are from  
> running the "sudo port upgrade outdated" command except perhaps by  
> looking at the timestamps. The latter do correspond to times when  
> "sudo port upgrade outdated" was running.
> I have 2GB RAM installed and the only other thing running was  
> Firefox 3.6 (and, while I was seeking help on IRC, Colloquy).
> Any ideas about how I should proceed?
> What is the command are you using to install boost?
> I was using "sudo port upgrade outdated".
> Are you selecting variants?
> No, I was just using the command above.
> Verifying your disk with Disk Utility:
> Now that I've got rid of boost, I've run "sudo port upgrade  
> outdated" again and seems to be running OK now, touch wood: not  
> eating up HDD space like before. Once that finishes running, I'll  
> try verifying the disk with Disk Utility.
> 3GB is not a lot of disk but you know that.
> Yep, I've got a big Windows Vista Boot Camp partition hogging most  
> of the HDD. I intend to resize that at some point, or else replace  
> it with Win XP or Win 7 to slim it down, but haven't had the chance  
> to do so yet.

Yes, I got rid of my boot camp partition and moved to vmware fusion on  
my laptop do to disk space. The dynamic resizing of the virtual  
machine image reduces wasted space. This also allows for the temporary  
moving of your virtual machine image to external storage when a  
temporary need for system disk arises.

Boot Camp is nice for some things (games) but I have found more  
advantages with virtual machines. I don't play computer games. If I  
did and needed windows I'd just setup a windows game machine.

// Brad

// Brad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20100217/02d88da8/attachment.html>

More information about the macports-users mailing list