InsightToolKit did not build

Ryan Schmidt ryandesign at
Fri Jan 1 17:47:01 PST 2010

On Jan 1, 2010, at 19:21, Frank J. R. Hanstick wrote:

> 	Updated to MacPorts 1.8.2, upgraded all the installed ports, and then tried to install insighttoolkit.  Installation failed and I reran the installation with debug enabled and got the following:

I saw your previous message on this topic on December 24, whereupon I tried to build InsightToolkit to see what happened for me. I did not realize how large this port is. With Snow Leopard on my 2.2 GHz MacBook Pro with, I think it took over 12 hours and over 8 GB of disk space to build, after which it said it ran out of resources (I think it said memory -- this machine has 4 GB RAM and > 50GB free disk space). I simply re-ran the port install command and it completed successfully; it takes 1.6GB of disk space after installation.

If retrying (multiple times if necessary) does not lead to a successful build for you, please file a ticket in the issue tracker, as always, with as much debug output and other information about your system as you can produce. Using will also help reduce confusion and aide in reading the log.

More information about the macports-users mailing list