error report when trying to install php/mamp

Ola Lundén ola.lunden at
Wed Jan 6 14:11:47 PST 2010

Ok, so I uninstalled macport and installed it again and now it seems to 
work fine. I'll just have to figure out how to make use of php52 and 
mysql. Maybe I'll come back with new questions. Thanks for now!


On 1/4/10 8:17 PM, dlc wrote:
> I had the same failure over a week ago after a port selfupdate showed 
> help2man out of date.  I did a port clean --all and a new selfupdate a 
> few days later and the upgrade succeeded.
> On Leopard, PPC G4.
> On Jan 4, 2010, at 12:51 PM, Joshua Root wrote:
>> On 2010-1-5 05:30 , Ola Lundén wrote:
>>> Ok, so I've checked that the file "libinintl.dylib" exists, I've
>>> de/activate gettext and found the file. But I still get the same error
>>> message running my installation.
>> Looking at the command in your output again, it's missing
>> -L/opt/local/lib, which would certainly cause the failure. When I build,
>> it's
>> /usr/bin/gcc-4.2  -o -fPIC -bundle -L/opt/local/lib
>> bindtextdomain.c -lintl
>> as opposed to your
>> /usr/bin/gcc-4.2  -o -fPIC -bundle bindtextdomain.c
>> -lintl
>>> When I ran the "lipo -info" command it returned:
>>>    Non-fat file: /opt/local/lib/libintl.dylib is architecture: x86_64
>>> Which I guess is ok since I've got an MacBook Pro running Snow Leopard.
>> Did you upgrade to Snow Leopard from an earlier OS version? If so, did
>> you follow <>? I'm thinking your
>> perl might be the wrong arch or something.
>>> About the other dependencies that failed to build: libtool automake
>>> autoconf help2man libxml2 mhash, shouldn't the installation process 
>>> take
>>> care of them as well? When should they have been installed?
>> After help2man. They were just blocked by it failing.
>> - Josh
>> _______________________________________________
>> macports-users mailing list
>> macports-users at
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list