Unable to Install CGAL

Pietro Maximoff segment_x at yahoo.com
Fri Jan 8 18:17:41 PST 2010

From: Ryan Schmidt <ryandesign at macports.org>
To: Pietro Maximoff <segment_x at yahoo.com>
Cc: macports-users at lists.macosforge.org
Sent: Fri, January 8, 2010 11:43:42 PM
Subject: Re: Unable to Install CGAL

On Jan 8, 2010, at 13:54, Pietro Maximoff wrote:

> I tried to install cgal but it always fails with the following error:
> ld: pointer in read-only segment not allowed in slidable image, used in ___gmpn_divexact_1 from /usr/local/lib/libgmp.a(dive_1.o)

You have a conflicting libgmp in /usr/local. It is not supported to have anything in /usr/local while using MacPorts because it often conflicts, as it has here. To resolve it, rename /usr/local (e.g. to /usr/local-off), clean the problem port (sudo port clean cgal) and try again. You can put /usr/local-off back to /usr/local after that, but will have to move it out of the way every time you want to build anything with MacPorts, so it's more convenient if you can delete /usr/local permanently and instead install all the software you need using MacPorts.


Thanks Ryan, it worked. 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20100108/fb2342fd/attachment.html>

More information about the macports-users mailing list