New install MAMP

Ryan Schmidt ryandesign at
Sat Jun 5 19:07:42 PDT 2010

On Jun 5, 2010, at 20:00, Scott Haneda wrote:

> Mac Mini that seems to be 64 bit capable...
>    $file `which ls`
>    /bin/ls: Mach-O universal binary with 2 architectures
>    /bin/ls (for architecture x86_64):	Mach-O 64-bit executable x86_64
>    /bin/ls (for architecture i386):	Mach-O executable i386

All that tells us is that your "ls" command contains x86_64 and i386 executables, which AFAIK will always be the case on Snow Leopard, regardless what processor you have. To see whether your Mac is actually 64-bit capable, run:

sysctl hw.cpu64bit_capable

If it says "1" your Mac is 64-bit capable; if it says "0", it isn't. (The first Intel-based line of Mac minis used Intel Core processors (which are not 64-bit capable)).

> $uname -a
> Darwin 10.3.0 Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09 PST 2010; root:xnu-1504.3.12~1/RELEASE_I386 i386
> Trying to install mysql 5 server, and get the entire MAMP thing going.  Install gets hung up on ncursesw and ncurses if I use +universal, 
> I did a little cleaning, and mysql5-server appears to be going now.  I have attached a tee'd log in case that helps.

The log doesn't contain anything useful; all it says is the muniversal portgroup couldn't begin ncursesw's configure phase because the directory it tried to create already existed, probably because you tried before, it failed, and you tried again without cleaning. Clean ncursesw, then try installing ncursesw +universal again to get the real error message, then show us that.

> As a test, I did built mtr +universal, and it was done in a minute and working.  So at the least, I have a compiler, and a machine that supports universal binaries.

All machines "support universal binaries"; the question is which architectures your machine can run (and, in some cases, build).

More information about the macports-users mailing list